(Bez tytułu)

Podgląd konfliktów replikacji - pomoc

Podgląd konfliktów replikacji ułatwia przeglądanie i rozwiązywanie konfliktów, które zachodzą podczas procesu scalania replikacji. Konflikty występują, kiedy te same dane są modyfikowane równocześnie w dwóch oddzielnych lokalizacjach, na przykład na serwerze Wydawca lub Sybskrybent lub na dwóch różnych serwerach Subskrybent. Te dwa rodzaje konfliktów mogą wystąpić w następujących przypadkach:

  • Aktualizacja i wstawianie konfliktów, kiedy te same dane są zmieniane w dwóch lokalizacjach. Jedna zmiana "zwycięża", podczas kiedy druga "przegrywa".
  • Usuwanie konfliktów, kiedy te same wiersze są usuwane z jednej lokalizacji i zmieniane w drugiej.

Konflikty te są rozwiązywane w oparciu o priorytet ustawiany podczas tworzenia subskrypcji lub na podstawie utworzonej przez użytkownika procedurze rozwiązywania. Podgląd replikacji konfliktów zezwala na podglądanie sposobu, w jaki te konflikty są rozwiązywane i wykonywanie zmian w tych rozwiązaniach.

Poniższa tabela pokazuje opcje i ich funkcje, jakie są dostępne w oknie dialogowym Podgląd replikacji konfliktów.

Uwaga

Specyficzne opcje, które pojawiają się, zależą od typu konfliktu, który wystąpił. Nie każda opcja pojawia się w każdym oknie dialogowym. Daty wyświetlane są w formacie czasowym ISO zamiast w formacie lokalnym.

Użyj | Aby
Przyczyna konfliktu | Obejrzeć określoną przyczynę konfliktu, który wystąpił i sposób, w jaki został rozwiązany.
Pokaż tylko kolumny zawierające konflikty | Wyświetlić unikatowy identyfikator GUID kolumny i tylko te kolumny, które zawierają konflikty.
Pokaż wszystkie kolumny | Wyświetlić wszystkie kolumny w wierszu.
Przechowaj istniejące dane | Zaakceptować bieżące rozwiązanie konfliktu.
Przechowaj poprawione dane | Zaakceptować bieżące rozwiązanie konfliktu, ale dołączyć poprawki wykonane w polach edycji.
Przechowaj usunięte dane | Zaakceptować bieżące rozwiązanie konfliktu, dane zostaną usunięte.
Ignoruj konflikt | Zaznaczyć konflikt jako rozwiązany bez wykonywania żadnych zmian. Prowadzi to do rozbieżności i powinno zostać rozwiązane jak najszybciej.
Zastąp danymi konfliktowymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane dane konfliktowe.
Zastąp istniejącymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane istniejące dane.
Zastąp poprawionymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany z uwzględnieniem wykonanych poprawek w polach edycji i przechować pokazywane dane poprawione.
Usuń dane | Usunąć dane pokazane w kolumnach.
Zarejestruj szczegóły tego konfliktu do późniejszego odwołania | Wykonać kopię konfliktu i przechowywać ją oddzielnym pliku dziennika do późniejszego wykorzystania. Plik jest przechowywany w katalogu Windows\profiles\user\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Bez tytułu)

Podgląd konfliktów replikacji - pomoc

Podgląd konfliktów replikacji ułatwia przeglądanie i rozwiązywanie konfliktów, które zachodzą podczas procesu scalania replikacji. Konflikty występują, kiedy te same dane są modyfikowane równocześnie w dwóch oddzielnych lokalizacjach, na przykład na serwerze Wydawca lub Sybskrybent lub na dwóch różnych serwerach Subskrybent. Konflikty mogą zachodzić również, kiedy zmiany danych wykonywane w jednej lokalizacji zakłócają ograniczenia w innej lokalizacji (konflikt rozbieżności). Po wystąpienia konfliktu rozbieżności, dane w dwóch lokalizacjach są inne do chwili rozwiązania konfliktu.

Konflikty te są rozwiązywane w oparciu o priorytet ustawiany podczas tworzenia subskrypcji lub na podstawie utworzonej przez użytkownika procedurze rozwiązywania. Podgląd replikacji konfliktów zezwala na podglądanie sposobu, w jaki te konflikty są rozwiązywane i wykonywanie zmian w tych rozwiązaniach.

Po zignorowaniu konfliktu rozbieżności należy rozwiązać jak najszybciej podstawowy konflikt w ograniczeniach danych. Rozpocznij od zarejestrowania szczegółów tego konfliktu, a następnie wyślij wpisy dziennika do swojego administratora systemu. Następnie sprawdź ograniczenia danych w każdej lokalizacji, aby upewnić się, że są one ze sobą zgodne.

Poniższa tabela pokazuje opcje i ich funkcje, jakie są dostępne w oknie dialogowym Podgląd replikacji konfliktów.

Uwaga

Specyficzne opcje, które pojawiają się, zależą od typu konfliktu, który wystąpił. Nie każda opcja pojawia się w każdym oknie dialogowym. Daty wyświetlane są w formacie czasowym ISO zamiast w formacie lokalnym.

Użyj | Aby
Przyczyna konfliktu | Obejrzeć określoną przyczynę konfliktu, który wystąpił i sposób, w jaki został rozwiązany.
Pokaż tylko kolumny zawierające konflikty | Wyświetlić unikatowy identyfikator GUID kolumny i tylko te kolumny, które zawierają konflikty.
Pokaż wszystkie kolumny | Wyświetlić wszystkie kolumny w wierszu.
Przechowaj istniejące dane | Zaakceptować bieżące rozwiązanie konfliktu.
Przechowaj poprawione dane | Zaakceptować bieżące rozwiązanie konfliktu, ale dołączyć poprawki wykonane w polach edycji.
Przechowaj usunięte dane | Zaakceptować bieżące rozwiązanie konfliktu, dane zostaną usunięte.
Ignoruj konflikt | Zaznaczyć konflikt jako rozwiązany bez wykonywania żadnych zmian. Prowadzi to do rozbieżności i powinno zostać rozwiązane jak najszybciej.
Zastąp danymi konfliktowymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane dane konfliktowe.
Zastąp istniejącymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane istniejące dane.
Zastąp poprawionymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany z uwzględnieniem wykonanych poprawek w polach edycji i przechować pokazywane dane poprawione.
Usuń dane | Usunąć dane pokazane w kolumnach.
Zarejestruj szczegóły tego konfliktu do późniejszego odwołania | Wykonać kopię konfliktu i przechowywać ją w oddzielnym pliku dziennika do późniejszego wykorzystania. Plik jest przechowywany w katalogu Windows\profiles\user\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Bez tytułu)

Podgląd konfliktów replikacji - pomoc

Podgląd konfliktów replikacji ułatwia przeglądanie i rozwiązywanie konfliktów, które zachodzą podczas procesu scalania replikacji. Konflikty występują, kiedy te same dane są modyfikowane równocześnie w dwóch oddzielnych lokalizacjach. Te dwa rodzaje konfliktów mogą wystąpić w następujących przypadkach:

  • Aktualizacja i wstawianie konfliktów, kiedy te same dane są zmieniane w dwóch lokalizacjach. Jedna zmiana "zwycięża", podczas kiedy druga "przegrywa". Dla takich konfliktów przeznaczona jest opcja przechowania istniejących danych (dane wygrywające) lub zastąpienia istniejących danych tymi, z którymi są w konflikcie (dane przegrywające). Jeśli przechowasz istniejące dane, pozostaną one w replice, która wygrała i Podgląd konfliktów replikacji firmy Microsoft doda je do repliki, której operacja aktualizacji lub wstawienia początkowo przegrała. Jeśli zastąpisz istniejące dane danymi konfliktowymi, repliki zostaną zmienione tak, że dane, które pierwotnie przegrały zostaną do nich dołączone.
  • Usuwanie konfliktów, kiedy te same wiersze są usuwane z jednej lokalizacji i zmieniane w drugiej.

Podgląd replikacji konfliktów zezwala na podglądanie sposobu, w jaki te konflikty są rozwiązywane i wykonywanie zmian w tych rozwiązaniach.

Poniższa tabela pokazuje opcje i ich funkcje, jakie są dostępne w oknie dialogowym Podgląd replikacji konfliktów.

Uwaga

Specyficzne opcje, które pojawiają się, zależą od typu konfliktu, który wystąpił. Nie każda opcja pojawia się w każdym oknie dialogowym. Daty wyświetlane są w formacie czasowym ISO zamiast w formacie lokalnym.

Użyj | Aby
Przyczyna konfliktu | Obejrzeć określoną przyczynę konfliktu, który wystąpił i sposób, w jaki został rozwiązany.
Pokaż tylko pola zawierające konflikty | Wyświetlić unikatowy identyfikator GUID kolumny i tylko te pola, które zawierają konflikty.
Pokaż wszystkie pola | Wyświetlić wszystkie pola w rekordzie.
Przechowaj istniejące dane | Zaakceptować bieżące rozwiązanie konfliktu.
Przechowaj poprawione dane | Zaakceptować bieżące rozwiązanie konfliktu, ale dołączyć poprawki wykonane w polach edycji.
Przechowaj usunięte dane | Zaakceptować bieżące rozwiązanie konfliktu, dane zostaną usunięte.
Ignoruj konflikt | Zaznaczyć konflikt jako rozwiązany bez wykonywania żadnych zmian. Prowadzi to do rozbieżności i powinno zostać rozwiązane jak najszybciej.
Zastąp danymi konfliktowymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane dane konfliktowe.
Zastąp istniejącymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane istniejące dane.
Zastąp poprawionymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany z uwzględnieniem wykonanych poprawek w polach edycji i przechować pokazywane dane poprawione.
Usuń dane | Usunąć dane pokazane w polach.
Zarejestruj szczegóły tego konfliktu do późniejszego odwołania | Wykonać kopię konfliktu i przechowywać ją w oddzielnym pliku dziennika do późniejszego wykorzystania. Plik jest przechowywany w katalogu Windows\profiles\user\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.


(Bez tytułu)

Podgląd konfliktów replikacji - pomoc

Podgląd konfliktów replikacji ułatwia przeglądanie i rozwiązywanie konfliktów, które zachodzą podczas procesu scalania replikacji. Konflikty występują, kiedy te same dane są modyfikowane równocześnie w dwóch oddzielnych lokalizacjach. Konflikty mogą zachodzić również, kiedy zmiany danych wykonywane w jednej lokalizacji naruszają reguły sprawdzania poprawności w innej lokalizacji (konflikt rozbieżności). Po wystąpienia konfliktu rozbieżności, dane w dwóch lokalizacjach są inne do chwili rozwiązania konfliktu.

Konflikty te są rozwiązywane w oparciu o priorytet ustawiany podczas tworzenia repliki lub na podstawie utworzonej przez użytkownika procedurze rozwiązywania. Podgląd replikacji konfliktów zezwala na podglądanie sposobu, w jaki te konflikty są rozwiązywane i wykonywanie zmian w tych rozwiązaniach.

Po zignorowaniu takiego konfliktu należy rozwiązać go jak najszybciej. Rozpocznij od zarejestrowania szczegółów tego konfliktu, a następnie wyślij wpisy dziennika do swojego administratora systemu. Następnie sprawdź ograniczenia danych w każdej lokalizacji, aby upewnić się, że są one ze sobą zgodne.

Poniższa tabela pokazuje opcje i ich funkcje, jakie są dostępne w oknie dialogowym Podgląd replikacji konfliktów.

Uwaga

Specyficzne opcje, które pojawiają się, zależą od typu konfliktu, który wystąpił. Nie każda opcja pojawia się w każdym oknie dialogowym. Daty wyświetlane są w formacie czasowym ISO zamiast w formacie lokalnym.

Użyj | Aby
Przyczyna konfliktu | Obejrzeć określoną przyczynę konfliktu, który wystąpił i sposób, w jaki został rozwiązany.
Pokaż tylko pola zawierające konflikty | Wyświetlić unikatowy identyfikator GUID kolumny i tylko te pola, które zawierają konflikty.
Pokaż wszystkie pola | Wyświetlić wszystkie pola w rekordzie.
Przechowaj istniejące dane | Zaakceptować bieżące rozwiązanie konfliktu.
Przechowaj poprawione dane | Zaakceptować bieżące rozwiązanie konfliktu, ale dołączyć poprawki wykonane w polach edycji.
Przechowaj usunięte dane | Zaakceptować bieżące rozwiązanie konfliktu, dane zostaną usunięte.
Ignoruj konflikt | Zaznaczyć konflikt jako rozwiązany bez wykonywania żadnych zmian. Prowadzi to do rozbieżności i powinno zostać rozwiązane jak najszybciej.
Zastąp danymi konfliktowymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane dane konfliktowe.
Zastąp istniejącymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany i przechowywać pokazywane istniejące dane.
Zastąp poprawionymi danymi | Pominąć sposób, w jaki konflikt został rozwiązany z uwzględnieniem wykonanych poprawek w polach edycji i przechować pokazywane dane poprawione.
Usuń dane | Usunąć dane pokazane w polach.
Zarejestruj szczegóły tego konfliktu do późniejszego odwołania | Wykonać kopię konfliktu i przechowywać ją w oddzielnym pliku dziennika do późniejszego wykorzystania. Plik jest przechowywany w katalogu Windows\profiles\user\Application Data\Microsoft\Database Replication\UnresolvedConflicts.log.